informaticaPC

Curso de OpenOffice Calc

Fórmulas, fórmulas matriciales, matrices unidimensionales, matrices bidimensionales...


Regístrate

Tus datos no serán compartidos, solo nosotros te enviaremos información y novedades

Fórmulas matriciales y matrices

Fórmula matricial: una fórmula matricial puede ejecutar varias operaciones y devolver un único resultado o varios resultados, siendo usadas básicamente para sustituir un conjunto de fórmulas estándar.

Matriz: es un conjunto de celdas o valores sobre el que se trabaja como si fuera un grupo.

Una matriz puede estar almacenada en celdas o ser un nombre constante, pudiendo ser:

  • Unidimensionales: un rango de celdas que ocupa una fila (matriz horizontal) o una columna (matriz vertical).
  • Bidimensionales: ocupa celdas en una o varias filas o columnas.

Insertar fórmulas matriciales

Si la fórmula matricial devolverá sólo un resultado hemos de seleccionar la celda en que deseemos introducirla, y si devolverá varios resultados hemos de hacer clic en el rango de celdas en que deseemos introducirla.

Por ejemplo:

Crear fórmula matricial

Para obtener el valor de la mercancía, en la celda 'B5' escribiremos la fórmula =SUMA(B2:B3*C2:C3) y presionaremos la combinación de teclas Ctrl+Mayús+Enter: veremos el resultado en la celda, y cómo se han añadido corchetes al principio y fin de la fórmula.

Matrices

Se pueden usar matrices constantes en las fórmulas en vez de referencias a celdas o rangos, para lo cual introduciremos directamente el conjunto de valores en la fórmula (entre llaves).

Tal y como hemos comentado anteriormente, pueden ser de uno de los siguientes tipos:

  • Unidimensionales: pueden ser a su vez horizontales (cuando sus elementos se separan con punto y coma como en el caso de este ejemplo: ={ "lunes" ; "martes" ; "miércoles" ; "jueves" }) o verticales (separados con barra invertida como ={1\2\3\4}).
  • Bidimensionales: también separan los elementos de las filas con punto y coma y los de las columnas con barra invertida, como por ejemplo ={1;2;3\4;5;6;\7;8;9}).
Primera página Anterior Siguiente Última página
Usamos cookies para ofrecerte una experiencia mejorada, el continuar navegando supone que aceptas su uso