informaticaPC

Teoría de la programación

Ejemplos de algoritmos en pseudocódigo (II)


Regístrate

Tus datos no serán compartidos, solo nosotros te enviaremos información y novedades

Pedir dos números enteros y mostrar 'Verdadero' si el primero es mayor

ALGORITMO Decir;
VAR
    ENTERO x, z;
INICIO
    ESCRIBIR("Dime dos números");
    LEER( x, z );

    SI( x > z )
        ESCRIBIR("Verdadero");
    FIN SI
FIN

Leer tres números y deducir si se han introducido en orden creciente

ALGORITMO N32;
VAR
    ENTERO a, b, c ;
INICIO
    ESCRIBIR("Dame tres números");
    LEER( a, b, c );

    SI (a < b) AND (b < c)
        ESCRIBIR("En orden creciente");
    SINO
        ESCRIBIR("En orden no creciente");
    FIN SI
FIN

Pedir dos valores y en caso de que no sean iguales indicar cuál es el mayor

ALGORITMO Leer;
VAR
    ENTERO x, y;
INICIO

    ESCRIBIR("Dame dos números");
    LEER(x, y);

    SI( x == y )
        ESCRIBIR("Son iguales");
    SINO
        SI( x > y )
            ESCRIBIR("x es mayor");
        SINO
            ESCRIBIR("y es mayor");
        FIN SI
    FIN_SI

FIN
Primera página Anterior Siguiente Última página
Usamos cookies para ofrecerte una experiencia mejorada, el continuar navegando supone que aceptas su uso