informaticaPC

Teoría de la programación

Ejemplos de algoritmos en pseudocódigo (III)


Regístrate

Tus datos no serán compartidos, solo nosotros te enviaremos información y novedades

Pedir un número al usuario y mostrar el nombre del día al corresponde (1=lunes)

Usando CASO:

ALGORITMO DIA_CASO;
VAR
    ENTERO d;
INICIO
    ESCRIBIR("Introduce un número del 1 al 7");
    LEER( d );

    SI (d >=1 ) AND (d <= 7)
        EN_CASO_DE d HACER
            1: ESCRIBIR("Lunes");
            2: ESCRIBIR("Martes");
            3: ESCRIBIR("Miércoles");
            4: ESCRIBIR("Jueves");
            5: ESCRIBIR("Viernes");
            6: ESCRIBIR("Sábado");
            7: ESCRIBIR("Domingo");
        FIN CASO
    SINO
        ESCRIBIR("El valor no es válido");
    FIN SI
FIN

EXPLICACIÓN: se pide un número al usuario y tras comprobar que está entre 1 y 7, mostramos el nombre del día. Sino es así mostramos un mensaje informando de que el número no es válido.

Usando PARA:

ALGORITMO DIA_PARA;
VAR
    ENTERO contador;
INICIO

    PARA contador DESDE 1 HASTA 7

        EN_CASO_DE contador HACER
            1: ESCRIBIR("Lunes");
            2: ESCRIBIR("Martes");
            3: ESCRIBIR("Miércoles");
            4: ESCRIBIR("Jueves");
            5: ESCRIBIR("Viernes");
            6: ESCRIBIR("Sábado");
            7: ESCRIBIR("Domingo");
        FIN CASO

    FIN_PARA

FIN

EXPLICACIÓN: creamos una variable auxiliar llamada 'contador' que usamos en un bucle PARA con el fin de repetirlo siete veces (el número de días de la semana): cada vez que se procese, mediante la sentencia de control CASO se comprueba el valor actual de 'contador' y se muestra el nombre del día de la semana adecuado.

Primera página Anterior Siguiente Última página
Usamos cookies para ofrecerte una experiencia mejorada, el continuar navegando supone que aceptas su uso