informaticaPC

Teoría de la programación

Ejemplos de algoritmos en pseudocódigo (V)

Regístrate

Los datos recopilados tienen como finalidad el envío de novedades sobre contenidos formativos propios (tanto en modalidad gratuita como de pago) y de terceros en calidad de afiliado, así como también noticias, información y otros contenidos relacionados con la informática y las nuevas tecnologías, siendo responsable de dicha información Francisco Javier Medina Medina (propietario de InformaticaPC.com).
Al obtener tu consentimiento los datos serán almacenados en el proveedor de E-Mail marketing MailRelay.
Por supuesto, en cualquier momento podrás hacer uso de tus derechos para acceder, rectificar, limitar y suprimir dichos datos.

Algoritmo con el que se asignan valores a un Vector de 10 elementos, y luego los muestra

ALGORITMO Vectores_1;
VAR
    ENTERO mi_vector[10];
    ENTERO contador;
INICIO

    PARA contador DESDE 1 HASTA 10
        ESCRIBIR("Dime un número");
        LEER( mi_vector[contador] );
    FIN_PARA

    PARA contador DESDE 1 HASTA 10
        ESCRIBIR( "El valor de la posición [", contador, "] es: ", mi_vector[contador] );
    FIN_PARA

FIN

Rellenar un Vector de 10 elementos con los números del 1 al 10

ALGORITMO Vectores_2;
VAR
    ENTERO mi_vector[10];
    ENTERO contador;
INICIO

    PARA contador DESDE 1 HASTA 10
        mi_vector[contador] <- 1;
    FIN_PARA

FIN

Explicación: la primera posición del Vector quedará con un valor de 1, la siguiente con valor de 2, y así consecutivamente.

Mostrar los valores de las posiciones pares de un Vector de 20 elementos

ALGORITMO Vectores_3;
VAR
    ENTERO mi_vector[20];
    ENTERO contador;
INICIO

    PARA contador DESDE 1 HASTA 20 INCREMENTO 2
        ESCRIBIR( "El valor de la posición [", contador, "] es: ", mi_vector[contador] );
    FIN_PARA

FIN
Primera página Anterior Siguiente Última página
Usamos cookies para ofrecerte una experiencia mejorada, el continuar navegando supone que aceptas su uso